The official Novation forum

Naming Plug-In Instances

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

9 posts / 0 new
Last post
mixmonkey
Offline
Last seen: 1 year 10 months ago
Joined: 11/30/2014 - 13:21
Naming Plug-In Instances

I can't seem to name indiviual instances of plug-ins as described on page 12 of the Automap manual. Well, I can type in the names ok but when the project is re-loaded, they've all reverted back to the default name, making the browser feature somewhat useless.

 

Does this work for anyone else? I'm talking about 3rd party plug-ins here, not the ones built into Logic (these get a name injected based on the track name)

skijumptoes
Offline
Last seen: 1 year 6 months ago
Joined: 03/26/2013 - 13:22

Never actually used that function before, i will have a try tonight - I imagine it may be easier to name the instruments in Logic if this isn't working though, that manual was probably written back before Logic X was around, so things may have changed and it probably hasn't been reported to Novation as not working with X (I'm presuming thats what you're using).

Just so i'm clear when i try this, are you trying it on instruments or effects?

mixmonkey
Offline
Last seen: 1 year 10 months ago
Joined: 11/30/2014 - 13:21

Either instruments or effects, but 3rd party wrapped plug-ins, not the ones that come with Logic. I use both Logic 9 and X (compatibility with collaborators) and it doen't work on either.

What's frustrating about this is that everything else recalls as expected. Any changes to an individual map (that changes it from the default), parameter names and what group it belongs to reload fine. Just not the name.

I like to use the Duende channel strip. Because I can't set a name for each instance ie bass, kick etc, all I see in Browser view is pages full of 'SSLChan' :-( As I said before, I can enter the name in the Mapping Editor, but it doesn't get saved or recalled.

Thanks for giving this a try :-)

skijumptoes
Offline
Last seen: 1 year 6 months ago
Joined: 03/26/2013 - 13:22

Hi Mate,

I get the same behaviour too, so it's not just you - I can see that being a handy little tip if it worked too, hopefully a mod will read this and take note to the automap team to have it fixed in the next release.

If i'm honest i don't know the correct way of even recording something like this officially, other than raising a technical support ticket i suppose?

http://www.novationmusic.com/answerbase/en/contact.php

mixmonkey
Offline
Last seen: 1 year 10 months ago
Joined: 11/30/2014 - 13:21

Glad it's not just me :-)

I've had an email exchange with Tech Support, but you know how those things go- kinda difficult to convince them that their software's broken. The support guy said he'd pass the message on, so fingers crossed.

I know I can just click on the plug-in on the screen, but the whole point of a control surface is that you shouldn't have to. Everything else gets saved in the xml file in: ~Library/Application Support/Novation/Automap Universal/Mappings/Instances/ZeRO MkII, why not the name?

skijumptoes
Offline
Last seen: 1 year 6 months ago
Joined: 03/26/2013 - 13:22

Just been having a play around, even if you adjust the .automap files to include the name tags they are re-written when the project is opened so can't even fool it into working, the same thing happens with Ableton too... Maybe it's osx specific issue. 

Even so, now i know you can do such a thing, i'm really interested in seeing this fixed too, as i'm forever creating my own custom channel strips, and to be able to name them within the display would be awesome, most of the time it looks like gibberish!

Just realised the importance of that folder too! And it explains why sometimes my SL gets a new ID and my mappings reset back on projects which previously worked - there's a folder for each device id, so if that changes you lose those instances - damn, i love automap, but at the same time it scares me that the whole thing is going to just crumble one day!!  Just had a hunt through time machine backups and i've had up to 9 instances of the same device in that folder over the past year!

joaoboullosa
Offline
Last seen: 1 year 10 months ago
Joined: 11/13/2014 - 16:29

The one and most annoying is the fact that in Logic Pro X, the Mixer Automap, that should be treated like another "thing" and not as a Plugin Automap, it's not. And whenever i open my default template, the device (mixer) is named after the projects last track (within the mapping), meaning it's called Crash, and it doesn't recall the change after renaming it in the Automap GUI.

It's a huge matter to have those names correctly displayed on the hardware, otherwise is much difficult to use it as a standalone controler.

So...+1 one very interested to see this solved.

Salem Beats
Offline
Last seen: 2 years 3 months ago
Joined: 01/12/2015 - 19:25

Confirmed the issue here, running an up-to-date installation of Windows 8.1 x64 using the latest Automap Beta (4.9b2).

In fact, I went all the way back to 3.7.4 to see whether this feature was working in a prior version, and it didn't seem to work with that old version either!

I've never really attempted to use this functionality, since I tend to use the "Focus follows plug-in" setting.
However, it'd be nice to have it working, especially for those of us who use multiple devices. After all, when you're using more than one Automap-enabled device, "focus" applies only to the selected controller.

-Ki
LearnAutomap.com - http://www.LearnAutomap.com/

mixmonkey
Offline
Last seen: 1 year 10 months ago
Joined: 11/30/2014 - 13:21

Still broken in the final release of 4.9, obviously not a priority for Novation.

They've only had a year to fix it, despite it being documented as a feature in the user manual since at least the release of version 3 (and still is: page 12, item 2)

Sure you can type the name into the field and it stays until the project is closed, but it isn't saved and therefore not reloaded.

Quite useless.