The official Novation forum

General USB Problems

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

3 posts / 0 new
Last post
Raven80
Offline
Last seen: 1 year 6 months ago
Joined: 10/15/2015 - 08:34
General USB Problems

Hello,

 

I have a new PC and use Windows 7 Pro 64 Bit.

(Intel Core i5-4590; Asus B85M-G; 2x 8 GB HyperX-Savage CL9 DDR3 1600; Sharkoon WPM500 Bronze) 

The PC has 6 USB ports.

When I connect the BS2 to one of the USB ports,

it often happens that Windows writes, "Unkown device".

The BS2 itself can be turned on and used without problems.

However, I need it in Windows to work in my DAW, but as said it almost never gets recognized.)

 

When I use the BS2 power supply and connect the BS2 with my PC,

it seems to work without problems.

(I haven't tested it so many times, but it seems it always worked.)

 

I also tried a USB to 2x USB A adapter.

The one jack was connected with my PC and the other one to a USB power supply.

It seems it didn't work either...

 

Any idea what the problem could be?

What experience did you make by using the BS2 with USB only?

 

Best regards

matthewk.novation
Offline
Last seen: 1 year 5 months ago
Joined: 03/20/2015 - 21:41

Hi Raven80,

It sounds as though the issue is only when attempting to bus-power the unit as the issue does not occur when using the PSU. This could be due to power setting on the PC sufficiently allowing the device to connect, but it may be worht optimizing the computer. Here is a link to the Windows 7 optimization guide:

http://global.novationmusic.com/answerbase/optimising-your-pc-for-audio-...

It would also be worth checking to see if there are any driver updates from the computer/motherboard manufacturer's website as this could affect the performance of the USB ports if they are running out of date drivers.

Matthew Kurpakus // Novation Technical Support

Raven80
Offline
Last seen: 1 year 6 months ago
Joined: 10/15/2015 - 08:34

Hello and thank you for your reply.

The link you posted is indeed very interesting.

 

I think I solved the problem in another way, though.

On Amazon I bought a 7 port USB hub which has an own power supply.

So my idea was to connect the BS2 to the hub and the hub to the PC.

(Additionally using the extra power supply.)

 

Well I tried it about 4 times and it always worked perfectly.

Strangely/luckily I don't even need to use the extra power supply.

 

I also bought a device which shows the power that goes to a device.

(Some kind of USB power monitor with an integrated display.)

It always showed 5V and 0.23A - 0.24A.

(I expected to see 0.5A)

Didn't really matter if I connected the BS2 to my laptop, PC, hub etc.

 

Anyway I think I can live with that.

Probably I can connect some other devices to the hub and the BS2 directly to my PC.

(Should be the same.)

 

Best regards