The official Novation forum

Circuit and Logic X

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

3 posts / 0 new
Last post
Piers83
Offline
Last seen: 1 year 8 months ago
Joined: 12/14/2015 - 10:21
Circuit and Logic X

I tried hooking up my Circuit to Logic X last night. After a bit of fiddling, I got the two to get on however I one issue. I can set up three tracks and have them set to channels 1, 2 and 10, for the 2 synths and drums (respectively) and then record various parts from Circuit into Logic. When I play it back however, the drums always seem to play out of channels 1 and 2, As well as 10. On top of this, they play seem to trigger notes that I haven't told them to trigger which is the most frustrating thing of all. Has anyone else has this issue? The way to work around this is to mute the drums as I record bits in individualy, but it seems a bit pointless to do that knowing that the channels are split.

 

I'm not the most technical, so i wouldn't be surprised if I changed a wrong setting or something, but any help with this would be most appreciated.

 

mzero
Offline
Last seen: 1 year 7 months ago
Joined: 10/15/2015 - 04:22

I suspect that you have the three tracks recording all channels - but only playing on 1, 2, and 10. I'm not a Logic X user, but I know that in other DAWs this is often the default set up. (As they want you to easily record from what every controller you put your fingers on.) Did you checked that recorded MIDI in each track is just from one channel?

skijumptoes
Offline
Last seen: 1 year 8 months ago
Joined: 03/26/2013 - 13:22

Do you have 'auto-demix by channel' in the recording preferences of Logic enabled?  If you multi-track record without this enabled all the data will go in to a single track across all channels.