The official Novation forum

Circuit - The Editor

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

14 posts / 0 new
Last post
darenager
Offline
Last seen: 1 year 5 months ago
Joined: 11/05/2015 - 00:48
Circuit - The Editor

Great work on the editor! One thing that would be handy is when changing the macro's have a indicator on the mapped parameters reflect the macro setting, so for example if you have a macro mapped to resonance when the macro knob is turned the value is indicated with dot or something on the resonance control.

Leptic tec
Offline
Last seen: 1 year 5 months ago
Joined: 12/19/2015 - 11:10

i don't success to launch the editor on my pc but i update the firmware

Leptic tec
Offline
Last seen: 1 year 5 months ago
Joined: 12/19/2015 - 11:10

i finally success to use the editor with the circuit and wooh , it's like 2 ultranova under the fingers , thanks for the present novation

robotunes
Offline
Last seen: 1 year 5 months ago
Joined: 12/19/2015 - 03:00

Leptic tec, how did you make it work? Mac or WIndows?

Leptic tec
Offline
Last seen: 1 year 5 months ago
Joined: 12/19/2015 - 11:10

you need to dl the zip called "Novation X Isotonik Circuit Editor Windows Standalone" i'm on windows but there is one for mac and you just have to plug the circuit and launch circuit.exe

follow what they say for mac

ashleyjamesbrown
Offline
Last seen: 1 year 5 months ago
Joined: 12/20/2015 - 22:59

Cannot get the mac standalone version to run under Mavericks at all. Have got Max 7 demo (along with 5 full and 6 demo) yet every time i double click to run it it just quickly opens and closes again on the taskbar. I do only have Ableton live 8 and max for Live 6 but the point was this could run standalone without anything other than Max 7 so I am fairely sure there is no conflict of these other req

Has anyone managed to ge the standalone to run on a Mac yet ?

 

edit: having removed the link to max in my ableton prefs and pointing to the downloaded version of max 7 it stated it was corrupt and then it auto downloaded a new version of max7 for em from the redirect from ableton.com. Choosing this in Ableton made the max for live version work even though the standalone one does not. SO for know I can access and update using the editor inside ableton (not quite the point but it works)

 

edit edit again: beta testing with the guys at isotonik for a fix for a full standalone working version for max osx

darenager
Offline
Last seen: 1 year 5 months ago
Joined: 11/05/2015 - 00:48

feature request - back up all sessions, back up single session, session manager for moving and changing positions of sessiions.

Tarekith
Offline
Last seen: 1 year 5 months ago
Joined: 01/01/2016 - 10:52

darenager wrote:

feature request - back up all sessions, back up single session, session manager for moving and changing positions of sessiions.

 

Yes please, I'd love to see this too!

 

 

 

 

isavedlatin1987
Offline
Last seen: 1 year 6 months ago
Joined: 12/26/2015 - 16:25

I'm having an issue where every time I download the Mac Standalone version from Isotonik it says that the file is damaged and will not open.  Very strange.  Any one else have this issue?

 

 

isavedlatin1987
Offline
Last seen: 1 year 6 months ago
Joined: 12/26/2015 - 16:25

Okay, already figured out the issue.  Seems to be working fine now.

Bulaw
Offline
Last seen: 1 year 5 months ago
Joined: 04/12/2013 - 20:34

I had the same issue with the "damaged file" but figured it out too. But now I can't get the stand alone to communicate with the Circuit. The plugin in ableton works, but not the stand alone. Anybody else experience this?

Edit:

Tried again and it worked. Not sure what I did different. Maybe pluging in usb before booting the software? Idk

ashleyjamesbrown
Offline
Last seen: 1 year 5 months ago
Joined: 12/20/2015 - 22:59

Bulaw wrote:

I had the same issue with the "damaged file" but figured it out too. But now I can't get the stand alone to communicate with the Circuit. The plugin in ableton works, but not the stand alone. Anybody else experience this?Edit:Tried again and it worked. Not sure what I did different. Maybe pluging in usb before booting the software? Idk

 

if the Circuit i not powered on when you open the application then it wont see it right away. You can click the isotonik logo to attempt to reconnect to the circuit and it will then connect and work.

 

SO two choices - power up circuit before you open editor OR open editor, power up circuit and click the logo to connect (might need more than one try but does work)

 

 

squ80
Offline
Last seen: 1 year 5 months ago
Joined: 01/04/2016 - 22:50

Damn! Another hardware device that i need to hook up to a computer to explore its full potential. I wish it would at least work with Windows XP. I guess i'm getting old. And lazy.:)

squ80
Offline
Last seen: 1 year 5 months ago
Joined: 01/04/2016 - 22:50

So i got windows 7 now. Yeah!!! The editor is so dope! Brings the Circuit to a whole new level. The ability to program the macros blows my mind. Now i love this little machine even more.