The official Novation forum

Circuit - Isotonik Editor Issue

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

2 posts / 0 new
Last post
Cires78
Offline
Last seen: 1 year 3 months ago
Joined: 01/05/2016 - 00:32
Circuit - Isotonik Editor Issue

Hi People,

I've a wee problem with the Circuit and editor. Running the stand alone version on 64bit Windows 10. When I have the sequencer recording and I input drum notes, it seems to also record the same notes on Synth 1. i.e. when I put in some BD notes, I also get a C or whatever playing at the same time. Using Midi-Ox, I can see two note on messages, one on ch 10 and another on ch 1.

All the patch editing side seems fine. Playes and records OK connected to usb when the editor isn't running.

Anyone else noticed a similar issue? I've e-mailed the guys at Isotonik, but I'm not sure if it's an editor issue, a Circuit issue, or something with my setup.

Thanks,

Eric

robotunes
Offline
Last seen: 1 year 3 months ago
Joined: 12/19/2015 - 03:00

That should have been fixed in the newest version. Download it again and if you have trouble, contact Isotronik Studios to get faster support.