The official Novation forum

Dud Impulse, Broken Support Link

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

6 posts / 0 new
Last post
Biagio
Offline
Last seen: 2 years 3 months ago
Joined: 06/27/2015 - 05:33
Dud Impulse, Broken Support Link

Hi,

 

I’m really frustrated with my Novation Impulse.  It's always been a little flakey, however, right now, it’s a brick after the most recent update.  I’ve tried every step on the site -- Different USB cables, different computers (a newish macbook pro on Mavericks, a macbook on Yosemite, and a newish iMac on Mavericks), factory reset, double checking to see if the most recent update failed, all the midi tips, tricks and resets, etc, etc.  The only way to get the display to even light up is to hold shift, +, and - and then plug in the keyboard.  It sticks on a couple of menus, then goes black.

 

Furthermore, at this time, this ink for help:

 

http://us.novationmusic.com/answerbase/contact

 

which is listed all over this site, goes into a permanent redirect loop in Chrome, Safari, and Firefox (tested on two different computers.)

 

Needless to say, my experience thus far, with both the keyboard and Novation support, has been less than ideal.

 

After visitng Guitar Center where I bought it, and explainig my predicament, they said these issues are rare with the Impulse, and feel I have a "dud" (their words.)

 

I would like a replacement keyboard or a refund.  Please advise how to proceed.

 

Best,

Biagio

 

 

Biagio
Offline
Last seen: 2 years 3 months ago
Joined: 06/27/2015 - 05:33

I wanted to add to this update that as a last ditch effort I purchashed a powered USB hub.  That still did not solve the issue.  I did test that powered USB hub with several other devices and it worked on all of them, so it was not the powered hub (yes, it was powered.)  The problem reamins the Impulse.

 

I look forward to hearing back from someone on how to replace or be refunded for this keyboard.  Thanks.

Biagio

Biagio
Offline
Last seen: 2 years 3 months ago
Joined: 06/27/2015 - 05:33

Also, the support link:

http://us.novationmusic.com/answerbase/contact

Still returns a redirect loop on every browser I've tried it on.  Attempting to attach a screen shot below.

skijumptoes
Offline
Last seen: 1 year 10 months ago
Joined: 03/26/2013 - 13:22

Link works fine for me mate, not sure what's going on there?  Have you tried viewing it in privacy mode or whatever is the equivalent on your prefered browser? Could be some session data going a bit nuts.

Also, how old is the unit? Can you not get a replacement from the retailer? Normally that's generally what should happen in the first 12 months, at least in the UK it is.

 

 

Biagio
Offline
Last seen: 2 years 3 months ago
Joined: 06/27/2015 - 05:33

Hey SkiJumpToes,

Thanks for your reply.  I called support this morning and they were helpful.  I'm in warranty, so they'll fix it.  

I also sent them the photo of the site being down, and they told me:

"As for the issue with the site, it seems that there was an issue that caused certain customers to not be able to see the page properly. This has since been rectified. You should now be able to get to the site with no issues. "

As of a few hours ago I can now access the support site, so they did, indeed fix it (at least where I'm at.)

I should say my experience with the phone support was really positive.  Guess I got a little nervous when it seemed their own support site didn't work.  Glad to know

1.  They site wasn't working but they did fix it.

2.  They do respond quickly via phone.

My bad luck this all went down on a Friday night :-)

BTW, if anyone in America has any issues, this is the phone number I called to talk to support:

(310) 322-5500

Best,

Biagio

skijumptoes
Offline
Last seen: 1 year 10 months ago
Joined: 03/26/2013 - 13:22

Nice one mate, i've been reading these forums for a while now, and i see many people complain at the lack of support from Novation, and it's a shame that they get this reputation - Because, like you've experienced, if you give them a call and talk to them they are really really good, and very thorough in getting your issue sorted out. 

The problem, i think, is that most people don't want to call using telephone anymore, and so usually send a ticket request in, sit waiting for a response for a few hours, and then come on this forum and rants about them in the meantime.... Then they come back the next day or so saying how great Novation were with support.  So yes, if you want immediate response give them a call!!! :)

Anyway, i hope it gets sorted for you.