The official Novation forum

Launchkey 25 mkII not recognized

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

2 posts / 0 new
Last post
alexis2hey
Offline
Last seen: 1 year 10 months ago
Joined: 01/06/2016 - 12:55
Launchkey 25 mkII not recognized

Hello,

I recently bought a Launchkey 25 mkII and it worked perfectly with FLStudio 12 on my sister's computer (win 10 btw), but when I tried to plug it into my computer (win7), it says "Unknown Device" (with an exclamation mark in the device menu in windows). I've already installed all the drivers and firmwares I found on the internet but it still doesn't work. (It doesn't appear in the MIDI menu of FlStudio too...)

I've already tried other USB ports (3.0 and 2.0).

Thx,

Alexis.

matthewk.novation
Offline
Last seen: 1 year 10 months ago
Joined: 03/20/2015 - 21:41

Hi Alexis2hey,

Sorry to hear about the difficulties conecting the device to your computer, but we are more than happy to help. Please feel free to contact us through the following link so we may investigate further:

https://global.novationmusic.com/answerbase/contact

Matthew Kurpakus // Novation Technical Support