Launchkey 25 problems on a Windows 8.1 laptop

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

39 posts / 0 new
Last post
egoje3
Offline
Last seen: 3 years 1 month ago
Joined: 02/11/2014 - 12:29
Launchkey 25 problems on a Windows 8.1 laptop

I have just purchased a Launchkey 25 and want to use it with a Windows 8.1 laptop. But there seems to be no connection and no sound comming through. It runs fine on an old Windows XP pc.

Are there any solution to the Windows 8.1 issue and can anyone tell me what t do and how to do it.

Thanks.

Carsten / Denmark

Taylor
Offline
Last seen: 1 year 2 months ago
Joined: 07/24/2013 - 17:12

Hello Egoje3, 

I suggest you get in touch with our support team via http://bit.ly/NovationSupport - I don't know of any specific reported issues with Windows 8 and Launchkey, so it may be something else; they'll troubleshoot it with you. :)

Best,
Taylor

egoje3
Offline
Last seen: 3 years 1 month ago
Joined: 02/11/2014 - 12:29

I did contact the support team two days ago, but haven't heard from them yet. Case 265164.

Carsten

Taylor
Offline
Last seen: 1 year 2 months ago
Joined: 07/24/2013 - 17:12

Hello Carsten,

We ask you please leave up to 48 hours for our tech team to respond - they work through cases in the order they came in, and it may take a day or two for them to reach yours! :)
I'm sure they'll be with you soon! If not, just let me know and I'll go check what the hold up is all about!

Thanks for your patience,
Taylor

midiblazer
Offline
Last seen: 3 years 3 weeks ago
Joined: 01/11/2014 - 19:36

They need to make a driver download for windows 8.1, I spent a month trying to get my Launchkey to be recognized in my DAWs. The answer tech support had for me was to send me out a magic usb cord. After a month of frustration I gave up, got my refund and bought an Axiom. 

midiblazer
Offline
Last seen: 3 years 3 weeks ago
Joined: 01/11/2014 - 19:36

Btw, it did also work perfectly on my old windows XP pc so it is definitely a windows 8/8.1 problem.  I even upgraded to windows 8.1 from windows 8 just to try and fix the problem...and I didn't want to do have to do that this early. Good luck!

Teekki
Offline
Last seen: 1 year 4 months ago
Joined: 02/20/2014 - 06:02

I'm having exactly same problem with my LK49 and W8.1... My LK works just fine with W7, but not with W8.1. Only way to get it working is unplug usb-cord and plug it back in several times. Sometimes I have to do that only few times and sometimes I need to do it like 50 times... It´s really frustrating to spend 15 minutes unplugging/plugging it back to get it installed properly after boot...

truthform
Offline
Last seen: 3 years 1 month ago
Joined: 02/17/2014 - 03:46

Same problem.

SmokeyJ628
Offline
Last seen: 3 years 4 weeks ago
Joined: 02/24/2014 - 14:51

Please add me to the list of people who cannot use their Launchkey on Windows 8.1  I submitted a ticket three weeks ago (Case: 262472).

The response said that it works fine with Windows 8, so it might be a bad USB cable.  Seriously?! I can't determine if they really believe there are no problems or if that's just a way to keep me busy while they work on it.

At any rate, I sent a reply stating that I had tried a number of USB cables (including a brand new one), and I had the same driver error each time.  I also used every USB 2 and USB 3 port on my system.  I provided links to posts in this very forum stating that they cannot get it to work in Windows 8 (with case numbers).  I also pointed out how this was a brand new, custom built DAW from Studiocat.  If it doesn't work on such a system, then it doesn't work.

That was two weeks ago.  No response since then.  I re-forwarded my email to them this morning, but my gut tells me that the "USB cable" fix is all I'm going to get particularly if they're in denial about the problems on Windows 8.1.

I bought the Launchkey to work with my new Windows 8 system.  I had to wait for the computer to be built and shipped.  During that time, a month passed so I can't even return my Launchkey.  While waiting on my new system, I used the Launckey on my Vista system without problems.  It's not the cables, Novation!   It's lack of Windows 8 compatibility.

Again, I just can't see *how* they can say there are no problems on Windows 8 systems. 

Teekki
Offline
Last seen: 1 year 4 months ago
Joined: 02/20/2014 - 06:02

I submitted ticket last thursday. No response yet. 

 

This is my last Novation gear ever for sure. Spend 170 euros for keyboard and then spend 100 euros more for Win7 license to get your new keyboard working. Priceless!!! :D

midiblazer
Offline
Last seen: 3 years 3 weeks ago
Joined: 01/11/2014 - 19:36

All they are going to do is tell you they will send you a usb cord that seems to work better...lol!!  That's their answer!!  I tried a bunch of usb cords, power sources, flipping on/off while saying 12 "our fathers" and 10 "hell mary" prayers...and nothing!!  I'm telling you guys, I was the first to post this Windows 8/8.1 problem in the forum and I got fed up and didn't feel like dealing with it after a month of not being able to create when I wanted to.  Meanwhile I would plug in my little M-Audio 25 and it was like old reliable with no issues ever, so my answer was to get a refund on my LK 61 and buy a new Axiom 61 for only $299. at B&H!!  I love it and have no problems whatsoever!!  I went with the LK61 because it was cheaper and the Axiom was $399. until I finally found the pot of gold of a price for only 299 at B&H.  No hard feelings towards Novation, but they don't want to make a driver download fix for windows 8/8.1...but they will be forced to because more people are buying windows 8 machines now...I didn't feel like waiting and dealing with the headache anymore!!  Good luck guys!

Teekki
Offline
Last seen: 1 year 4 months ago
Joined: 02/20/2014 - 06:02

Finally! I got mail from Novation support. They promised to send me that magical USB cord, that will fix the problem! Awesome!!! :D

 

FFS, why can't they admit that it´s an issue with W8 compatibility, not some problem with USB cord... 

skijumptoes
Offline
Last seen: 1 year 3 months ago
Joined: 03/26/2013 - 13:22

Hey, Teekki if we don't hear from you again at least we know what the magic ingredient is in those USB cords!!  ;)

 

 

(Poison) lol :)

idjhass
Offline
Last seen: 2 years 10 months ago
Joined: 05/28/2014 - 02:20

Here is the solution , 

 

dont ask where it came from !! 

to Novavtion, you guys owe me a launch pad lol :D

 

Go to device manager
Click on Universal Serial Bus Controlers
Plug in your Midi Controller to any USB 3.0 port
Once you see your device appear on the list Right click on it and go to properties

Click on the Events tab

 

from the Information box in the bottom you will notice your VID/PID/REV "Instance ID"

Mine say: Device USB\VID_0644&PID_800E/0100.     **!!yours will be different!!**

So my Flag is gonna be:  0644800E0100

 

Now on your Desktop's Taskbar: Right click on your Start button and select Run

Type in: Regedit

Click OK

Navigate to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/usbflags/

 

Now find the folder with your VID/PID/REV Instance ID (Mine is 0644800E0100)

On the right hand of the editor, Right click and select: New

Now select: Binary Value

Name it: osvc

Right click on it and select: Modify

Set the value: 00 00

 

Close the regedit window

Unplug and Plug back in your device... and Voila!!!

 

If it didn't work make sure you selected the correct folder with your correct VID/PID/REV

 

Good luck

dragonflyr
Offline
Last seen: 2 years 8 months ago
Joined: 06/15/2014 - 12:58

This "fix" from idjhass worked for me.  i've got a 64bit win8.1 ultrabook with various vst host's on it and everything worked good except ableton. had to plug the launchkey in multiple times to get it to be seen in ableton, and the "incontrol" would NEVER work.  Also have a win7 32bit desktop with the exact same version of ableton on it and everything was good. So, I tried this reghack suggestion on the win8 ultrabook, and amzingly it worked. I have rebooted about 5 times and shutdown/reopened ableton about a dozen times .. and all is good.

I still get the wierd connection/freeze issue when first firing up ableton .. where the launchkey sort of freezes for 10-15 seconds. But after that, it is all good.

I still hope Novation addresses this win8 compatability issue.

Anyway .. just awnted to pass along that this fix worked for me.

skijumptoes
Offline
Last seen: 1 year 3 months ago
Joined: 03/26/2013 - 13:22

If the fix helped you, It's actually a windows issue looking at what Microsoft staff have posted, so maybe worth hassling them also :-

(2nd post explains the issue)

http://answers.microsoft.com/en-us/windows/forum/windows8_1-hardware/usb...

dragonflyr
Offline
Last seen: 2 years 8 months ago
Joined: 06/15/2014 - 12:58

well ... the reghack fix worked for about 1 day .. now I'm back to the same probelm; launchkey intermittently detected in Ableton and "incontrol" never working.

Have we heard anything from anyone about these magic USB cables novation is sending out? is it really a viable solution?

 

in the meantime I will contact novation support and give this a few days. if no solid fix, I will return this device. I just cannot fight with it everytime I want to use it .. kinda kills all the fun and productivity!

skijumptoes
Offline
Last seen: 1 year 3 months ago
Joined: 03/26/2013 - 13:22

The magic USB cables has worked for some on here, i beleive there may have been a batch of poor quality cables shipped with the device, but i'm not 100% sure - but yes, definetly seen people where the cable sorted their issue out.

I'm using mac so it's very hard to see where the fire lays with all this smoke on win 8.1 and Impulses, i think if you have a problem you could be looking at anything from USB cables/Hub issues to Microsoft generic driver issues and possibly faulty hardware.  I really do feel for Win 8.1 users as it looks a big big problem across multiple midi devices.

Are you using a USB hub or anything? If so, can you try going straight into your pc to see if it helps?  This rules out any communication/power issues that could cause the connection form device to pc to fail.

dragonflyr
Offline
Last seen: 2 years 8 months ago
Joined: 06/15/2014 - 12:58

im going straight the the ultrbook with the supplied cable. 

 

alittle background .. i build system images that are deployed to hundered of systems on various hardware .. so i've dealt with compatability issues before.

everything was great in my IT world (for 10+ years) until the introduction of usb3 .. specifically chipsets with the intel usb3 (Intel USB 3.0 Extensible Host Controller) .. all sorts of issues, even on win 7. im still trying to determinine if this is realted to the launchey issue. last night i uninstalled/reinstalled the driver for the usb3 controller. the launchkey is still intermittently connecting. 3 times this morning the computer fired up and detected the launchkey fine (in device manager .. "sound, video, game controllers"), 2 times I had to plug/unpleg the device a few times until it shows up correctly. had to leave for work .. so will do more specific testing tonight. 

i will say this though ... you can chase this stuff in circles for DAYS. so, i'll probably re-image the ultrbook with a win7 build just to verifiy that it is for an absolute fact a win8 issue. that would rule out any possible hardware (ultrbook, launchkey, and cable) issues. 

thanks for some intel about the "magic" usb cable (helping some people). i guess in the meantime I'll open a ticket with novation and see if I can get one shipped to me. I want to resolve this in a week, otherwise I'll return the launchkey. I just don't have the time to mess with intermittent connections... that kills creative productivity and is NOT good for playing live!! Basically, from what I've read so far, I don't think there is an "etched in stone" fix .. it seems Novation is sort of stabbing away blindly at the issue. It would be nice to see something related SPECIFICALLY to Windows 8 issues in the support section of their site.

 

 

skijumptoes
Offline
Last seen: 1 year 3 months ago
Joined: 03/26/2013 - 13:22

The issue with the cable resolving issues, specifically with Win 8.1 users too has not only been on this forum, but a few others from different manufacturers.  Like you i've worked in IT for many years and i've always had the beleif that a cable either works, or it doesn't - the fact that people need a different cable for Win 8.1 really confuses me, unless of course it is a USB 3 thing.

Trouble is, it's very hard to see what are genuine issues, and what are people just getting a new lead, plugging in to a new usb port and everything working as a coincedence.

You're right though, there should be a section on the main page for owners - it doesn't put people off buying a product anymore to see issues reported on what many consider a sales page.  It shows committment to me, we've all moved on from that way of thinking into wanting more pro-active companies supporting us.

I sincerely hope you get this sorted as you seemed nicely informed to share you findings with the world.  Hope it doesn't come down to you having to return the unit.

dragonflyr
Offline
Last seen: 2 years 8 months ago
Joined: 06/15/2014 - 12:58

agree with all you say, skijumptoes. It is very hard to see the genuine issues through all the variables involving users/devices/os's, etc..etc.

I, too, am confused/puzzled by the "magic cable fix" .. but, I've seen stanger things! So, I'm all for trying it. 

I'll probably hang onto it regardless and eventually come accross a solid fix, or just slap win7 on the system. It was solid last night (still win 8.1).. as long as I FIRST make sure the device registers properly in device manager .. and then select the "'LaunchKey (InControl) port 2" in ableton>midi sync .. all is well. But, I did have to replug it in a few times to get it to register. Also ran USBDeview to clear out previously connectled usb devices .. trying to clean the "usb slate" as much as possible. 

 For home use I can get by with the present win8 connectivity wonkiness .. I'd be real nervous plating live though!  I'll probably fall back to a win7 system for live use until I feel more confident about the win8 compatability.

 I'll post any important finds or results . . .

dragonflyr
Offline
Last seen: 2 years 8 months ago
Joined: 06/15/2014 - 12:58

novation support emailed me the latest firmware.  it appears to have helped. i've had connection issues twice in the last week. but, it does appear to be a little more solid. i don't think it is THE fix .. but it has helped.  

 

skijumptoes
Offline
Last seen: 1 year 3 months ago
Joined: 03/26/2013 - 13:22

Did they explain what specifically is in this firmware which has improved it? Just thinking it may help you reach 'THE' final fix if it's clear.

dragonflyr
Offline
Last seen: 2 years 8 months ago
Joined: 06/15/2014 - 12:58

skijumptoes .. no, no specifics mentioned in the email.  here is the body of the email:

Thanks for your mail. Sorry to hear that you are having issues with your Launchkey. It seems that the Launchkey is having some issues with the firmware given that you are able to connect to your Windows 7 machine but not on your Windows 8 machine. Here are the steps to update the firmware to your Launchkey.

To upgrade the Firmware, please download the firmware update to your computer:

Download file here:



To upgrade the Firmware, follow these instructions:

1. Press and hold the record button on the Launchkey
2. Connect the Launchkey to a Windows 7 PC
3. Release the record button
4. Wait for the device to finishing connecting and Windows finish installing the driver, if this pops up.
5. Run the Launchkey updater software.
6. The Launchkey should display ‘up’ on it’s LCD, and the software will display the following:
7. Click the update button
8. The Launchkey will flash ‘up’ whilst the firmware is being updated
9. After the update process has finished the software should say “Update completed sucessfully"
10. Unplug and re-plug the Launchkey

Since the Launchkey can connect fine with the Windows 7 computer please make sure to use that computer to update the firmware.

Please let us know how you get along. If you are experiencing the same issues please contact us for further support.

Best regards.

skijumptoes
Offline
Last seen: 1 year 3 months ago
Joined: 03/26/2013 - 13:22

Ah no read.me or anything in that, interesting that the firmware revision is April 2014 - Shows they've been at work on this for a while, no doubt there's another one after this which may help even more once they're comfortable to give it out.

And on that note, anyone else thinking of downloading and using this i would imagine will be at your own risk as this is not a public firmware release.  Not that anything nasty is likely to happen, but just be aware that you may not be covered unless explicity asked by Novation staff to install it.

 

Edit: Just seen the link has been removed -ignore me! :)

dragonflyr
Offline
Last seen: 2 years 8 months ago
Joined: 06/15/2014 - 12:58

thanks skiijumptoes for bringing that to my attentionn that the file is not a public release. i deleted the link just to be safe. for anyone looking for it .. contact novation support. they supplied it to me pretty quick. 

Again .. it's been pretty stable so far on Win8. I decided to keep the Launchkey .. it's been more solid (than not) in Ableton and I just like the integration with ableton. I'll probably continue to use my 88 key yamaha controller for live use .. even though I did buy the launchkey to use live. When the Alesis VI61 is available, i might be real tempted to pick that up.  But, regarding the launchkey, it does play nice with ableton and the ipad apps are fun as well.

 

 

bernardo_cabral
Offline
Last seen: 2 years 6 months ago
Joined: 09/06/2014 - 22:27

hello guys, today bought my launchkey 25, and my DAW (REAPER) did not recognize, (I use windows 8), I read the comments from you and was already giving up, until i read what (idjhass) suggested. After following the indicated steps worked for me. Hope it works for everyone while novation does not update drivers.

Quote:
Go to device manager

Click on Universal Serial Bus Controlers
Plug in your Midi Controller to any USB 3.0 port
Once you see your device appear on the list Right click on it and go to properties

Click on the Events tab

 

from the Information box in the bottom you will notice your VID/PID/REV "Instance ID"

Mine say: Device USB\VID_0644&PID_800E/0100.     **!!yours will be different!!**

So my Flag is gonna be:  0644800E0100

 

Now on your Desktop's Taskbar: Right click on your Start button and select Run

Type in: Regedit

Click OK

Navigate to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/usbflags/

 

Now find the folder with your VID/PID/REV Instance ID (Mine is 0644800E0100)

On the right hand of the editor, Right click and select: New

Now select: Binary Value

Name it: osvc

Right click on it and select: Modify

Set the value: 00 00

 

Close the regedit window

Unplug and Plug back in your device... and Voila!!!

 

If it didn't work make sure you selected the correct folder with your correct VID/PID/REV

 

Good luck

my contact is facebook.com/he.bernardo if someone has similar problems and could not perform the above steps

cristianrisi
Offline
Last seen: 2 years 5 months ago
Joined: 09/28/2014 - 11:21

Hi,

same problems with my new Launchkey 25 and Windows 8.1. Anyone please can give me the new firmware? Thanks

PS: sorry for my little english!

NAGENDRA
Offline
Last seen: 2 years 5 months ago
Joined: 10/14/2014 - 09:53

http://www.youtube.com/watch?v=vDFKi2tVves

 

 

cristianrisi wrote:

Hi,same problems with my new Launchkey 25 and Windows 8.1. Anyone please can give me the new firmware? ThanksPS: sorry for my little english!

Teekki
Offline
Last seen: 1 year 4 months ago
Joined: 02/20/2014 - 06:02

I had to "upgrade" back to W8.1 from W7 and i was hoping that this reghack will fix the problem, but it didn´t and my LK49 isn´t recognized by Windows. This is so frustrating.... I contacted Novation Support and asked them to send me firmware updater... :/

mikenovation
Offline
Last seen: 2 years 4 months ago
Joined: 04/04/2013 - 17:10

Hi Teekki, 

I see you contacted Novation support, did we send you the firmware updater you requested?

Please respond with your case number so I can look in to this issue personally. 

Best regards, 

Teekki
Offline
Last seen: 1 year 4 months ago
Joined: 02/20/2014 - 06:02

mikenovation wrote:

Hi Teekki, I see you contacted Novation support, did we send you the firmware updater you requested?Please respond with your case number so I can look in to this issue personally. Best regards, 

 

Hi. I just checked my email and no, you haven´t send me firmware updater. I´d like to try if it helps, because now i have to unplug and re-plug it several times hoping it will install properly. I usually have to do that like 20 times before it happens...

 

Case 342514

 

Thanks!

 

 

Teekki
Offline
Last seen: 1 year 4 months ago
Joined: 02/20/2014 - 06:02

YES! Just got reply from Novation Support. They didn´t send me firmware updater. They told me to install Novation Automap. I had tried already and it didn´t work at that time because my Launchkey was recogniced as Launchpad and i couldn´t play with keyboard.

After few hours of swearing i decided to try that again and voila! my Launchkey installed properly without un-pluging and re-pluging it several times! After that i uninstalled Automap because i don´t want to use it. Uninstalling it didn´t uninstall Novation USB-drivers so now my Launchkey is using them instead on Microsofts Generic USB Audio drivers and i haven´t had any problems after booting my computer several times. Lets hope things stay this way! Thanks!

 

 

mikenovation
Offline
Last seen: 2 years 4 months ago
Joined: 04/04/2013 - 17:10

Hi Teekki,

Glad to hear your sorted, please let us know if you need any more assistance. 

Best regards, 

NAGENDRA
Offline
Last seen: 2 years 5 months ago
Joined: 10/14/2014 - 09:53

this fixed my problem in launch key 61

 

https://www.youtube.com/watch?v=vDFKi2tVves

 

hi.... search for impluse drivers which is also same as launch key

 

 

corbez
Offline
Last seen: 2 years 5 months ago
Joined: 10/23/2014 - 20:38

hello there, can you help me?

i'm gonna buy the launchkey 25 but i want to know if i can download abelton on two different PCs or i can download it once and only in one PC

thanks!

 

 

Davi Gonzaga
Offline
Last seen: 2 years 4 months ago
Joined: 10/26/2014 - 01:31

Lauchekey 49 sometimes does not recognize 8.1. is there any update firmware?

texet7
Offline
Last seen: 1 year 6 months ago
Joined: 09/26/2015 - 18:38
matthewk.novation
Offline
Last seen: 1 year 2 months ago
Joined: 03/20/2015 - 21:41

Hi guys,

See a few things going on in this thread and wanted to reach out. There are a couple different Launchkeys out now and we are more than happy to help set things up properly. If you are having any issues getting the Launchkey to work properly, please contact us through the following link so we may look further into resolving the specific issue occuring:

http://global.novationmusic.com/answerbase/contact

There was also a question regarding Ableton activations on a additional computer. The included Ableton Live Lite, is limited in features but fully authroized version of the full version. You absolutely can install the software onto another computer as it will allow 2 activations.

Matthew Kurpakus // Novation Technical Support