Launchkey 49 not changing midi channels in Ableton

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

1 post / 0 new
lordradish
Offline
Last seen: 1 year 8 months ago
Joined: 10/10/2015 - 03:41
Launchkey 49 not changing midi channels in Ableton

Hi,

 

I have a Launchkey 49, which I use with Ableton Live 9. Most things work fine, but I'm noticing a problem when changing midi channels.

 

For example, I have my Kontakt set up with several instruments in it, one for each channel. When I use Kontakt standalone, outside of Ableton, I'm able to change the channels andd play the corresponding instrument with no problems. However, when I try the same thing in Ableton, it seems to get confused with the track change command. When I press the two buttons simultaneously, like I'm supposed to, often, it will change the track, anyways, instead of the midi channel. When I am able to get the display to change the midi channel, it doesn't seem to tell Ableton the midi channel changed, as it still just sends channel 1. I do have the midi track in ableton set up to "all", for the inputs.

 

Is this a glitch or is there a workaround? I want to use Live in a performance setting, and that means I need to be able to change my midi channels on the fly. I can't currently do that.

Help!

Thank you.