Launchkey + Traktor Pro 2: LEDs output doesn't work

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

8 posts / 0 new
Last post
eicheevee
Offline
Last seen: 3 years 3 weeks ago
Joined: 08/06/2013 - 21:50
Launchkey + Traktor Pro 2: LEDs output doesn't work

Hello!

The problem is that LEDs don't respond to output mappings in Traktor (v 2.0.1).

In-/Out-Ports are set to "Launchkey 49", input and output buttons are mapped to the same function and note ("Play/Pause", Ch10.Note.E2, for example) and to the same deck. I've played with Controller/Midi Range values, but nothing happend.

For Launchpad this method works fine. What's the problem with Launchkey pads? I mean, it's not a hardware issue - in Ableton with InControl mode ON pads worked as it should be (green, yellow, red; different brightness; blinking etc).

 

P.s. Already wrote to support about that. No response after 5 days.

Taylor
Offline
Last seen: 2 years 2 weeks ago
Joined: 07/24/2013 - 17:12

Hello eicheevee,

I'm sorry to hear you haven't heard a response from support.
Would you mind giving me your case number, so I can chase it up for you?

Thanks,
Taylor

eicheevee
Offline
Last seen: 3 years 3 weeks ago
Joined: 08/06/2013 - 21:50

Got a message from support an hour ago, thank you.

 

MADD1
Offline
Last seen: 4 years 3 months ago
Joined: 09/26/2013 - 02:57

Can you fix the problem? How you did it?

mikenovation
Offline
Last seen: 3 years 2 months ago
Joined: 04/04/2013 - 17:10

@ MADD,

 

Please contact Novation Support:

http://us.novationmusic.com/node/2285

MADD1
Offline
Last seen: 4 years 3 months ago
Joined: 09/26/2013 - 02:57

They not respond...

eicheevee
Offline
Last seen: 3 years 3 weeks ago
Joined: 08/06/2013 - 21:50

Hi everyone. 

Sorry for not responding in this topic.

I talked with Novation Support and they said that there are no way to make LED feedback work in Traktor or anywhere else. 
The problem is in InControl feature. While every other controls (keys, faders, etc.) work on one midi channel, pads use two of them: one for regular mapping and another for InControl's LED feedback. Software like Traktor "talks" with controller only via one midi channel. The only software that can use both channels is Ableton. Ableton has some kind of "tricky mighty script" which other DAWs hasn't. So actually now it's others software delevopers' problem and not Novation's one. How tricky...

Anyway. if somebody somehow will make this thing works - write about it plz plz plz.

 

P.s. As for me, I doubt that Novation can't do anything with this issue. InControl is fine, why not to make possible to map LEDs in "regular" mode (IC off)? 

MADD1
Offline
Last seen: 4 years 3 months ago
Joined: 09/26/2013 - 02:57

@eicheevee 

I think the same. I'll not rest until i know how to use the LEDs. Must be a way to do it... 
I hope that someone know how.

And thanks for responding! :D