Pickup Function in Logic and Ableton not working properly

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

4 posts / 0 new
Last post
marcjoe
Offline
Last seen: 5 years 4 months ago
Joined: 06/09/2013 - 13:23
Pickup Function in Logic and Ableton not working properly

Hi, I have the Launchkey 49 since a few days, and I just can´t make the pickup function work properly.

 

In Ableton Live 8 I could narrow it down a bit:

 

When connection the Launchkey and starting Live, at first the Pickup mode works fine. As soon as I toggle the InControl with the button next to it and switch to normal Midi mode and back to InControl, it won´t work anymore. The rotary knobs still perform pickup, but as soon as I switch the mode here also and back, it´s not working anymore. This can then only be fixed after quitting Live and starting up again. Then it works until the same procedure is done once more....this is quite frustrating.

 

In Logic the problem is even worse:

 

Here Pickup Mode won´t work at all. I tried everything, switching the mode on and off in Logic preferences, switching Incontrol mode on the Launchkey. Actually I just found a workaround for the faders: In the control assing mode, just move a fader. The Control settings for it will appear. When you change the Feedback mode from "automatic" to "no dithering", It will actually pick up the faders!

I tried the same for the rotary knobs, but it won´t work with them. Sadly, they are no endless knobs, so I hope that maybe someone else has an idea how to make them work with "Pickup Mode". 

 

Anyone experiencing the same problems in Ableton Live and Logic?

fishgutt
Offline
Last seen: 4 years 6 months ago
Joined: 05/25/2013 - 15:21

I have a similar problem with live,where as the faders will work in pickup mode but the knobs just take control straight away making the parameters jump like crazy.

 

sometimes it works most of the time it doesnt.

Ksynth
Offline
Last seen: 5 years 4 months ago
Joined: 06/08/2013 - 00:45

I'm starting to think this is the worst product I've tried for Ableton Live.

Nothing works consistently.

I managed to get some control over an Absynth patch for a few moments. That vanished when I changed patches.

I've now given up until we hear some definite and detailed setup guidelines from Novation. Or some software update.

Considering sending this back through Amazon.

 

 

 

 

 

 

 

 

MiloMac
Offline
Last seen: 5 years 1 month ago
Joined: 03/20/2013 - 14:10

Hi all

I'm sorry to hear you're experiencing problems and inconsistencies with Launchkey.

Please contact our support team who will be happy to help:

http://novationmusic.com/answerbase/contact

Thank you.