The official Novation forum

Launchpad S dont work

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

4 posts / 0 new
Last post
FlaKiT
Offline
Last seen: 2 years 2 months ago
Joined: 03/13/2015 - 20:19
Launchpad S dont work

Hello,
my Launchpad S doesnt work anymore.
It ligthts up, but windos dont recognizes it. I tried everything, but nothing works.
I use Windows 7. Nothing like "Could not install USB driver" pops up. It just dont do anything.
Please help me.

 
PandaEyes
Offline
Last seen: 2 years 2 months ago
Joined: 03/15/2015 - 04:35

Hello, I have this problem too, Windows 7 32bit

 

Sonoquilibrium
Offline
Last seen: 1 year 10 months ago
Joined: 03/17/2015 - 10:49

I have just oposite problem.

I work with Ableton and it can recognize it, but I can not see any light on launchpad and in the Live session view I don´t see any connection. 

Piss,

Matej

hagaizz
Offline
Last seen: 1 year 10 months ago
Joined: 07/15/2015 - 18:47

I had the same problem, and after a long furstrating time I solved it!

I asked for help from the tech-support chat service. It's not working 24/7, but worthy!

The guy on the other side was very patient and helped me identify the problem.

If my solution will not help you, I strongly suggest use this service.

http://global.novationmusic.com/answerbase/contact

 

The Launchpad unit is "Class-compliant MIDI". That means it doesn’t require a third-party driver.

I am using windos 7 64 bit. and a "scarlett 2i4" USB audio interface by Focusrite.

In my case, Windows was using an unnecessary driver from Focusrite.

(I assume that the unwanted driver was in the system after I installed the audio-interface driver)

 

So these are the steps I did:

1. Go to Device Manager.

2. Expand "Sound, video and game controllers".

3. Look for the Launchpad S.

4. If it has a Yellow exclamation mark it probably means there is a driver problem. Right-Click and choose "Properties".

5. Select "Driver" tab.  the "Driver Provider" should be Microsoft. If it is by other provider it means it's adriver that doesn't fit Launchpad.

6. Click the "Unistall" driver button, and activate the delete option (very important!).

From now on the unwanted driver will not be available.

 

I hope it will help you as well.