Pre-listening Twitch with Traktor

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

6 posts / 0 new
Last post
Jimmy
Offline
Last seen: 3 years 6 months ago
Joined: 10/02/2013 - 21:10
Pre-listening Twitch with Traktor

Hello everyone, I state that I am not a DJ but I like to have fun at home, I recently purchased the twitch and use it with traktor, but I cannot do the prelistening, both decks end up on the master... I will surely have done something wrong. Someone can help me? Thank you in advance.

Taylor
Offline
Last seen: 1 year 3 months ago
Joined: 07/24/2013 - 17:12

Hello Jimmy,

Sounds like a routing issue! Can you send us a picture of your setup?

Thanks,
Taylor

Beatdoc
Offline
Last seen: 3 years 6 months ago
Joined: 10/25/2013 - 12:37

HI Jimmy. I also have the same Mistake. If you habe a Solution from Novation ( or anyonw out there) PLEASE write it down here.

I´d like to use the Twitch sone for a Gig....do you also have Problemes that the Phone Knobs ( CUE / Volume) work but you still get any Feedback in the Software??

 

Best Regards,

Beatdoc

jaytal
Offline
Last seen: 2 years 6 months ago
Joined: 10/16/2014 - 16:27

Hi, I'm having the exact same problem, this is my output settings right now. Master is mono since im running through a single aux cord. Any ideas?

Ottoderbusfahrer
Offline
Last seen: 2 years 5 months ago
Joined: 11/24/2014 - 17:26

Same problem with Traktor pro 2.6.8!!  Any Solution here?? The mapping from novationmusic.com doesn't run! need help!

 

PEACE

 

OTTO

SherpaPsy
Offline
Last seen: 2 years 3 months ago
Joined: 12/30/2014 - 09:38

UPDATE: Having read the Twitch Programmer's Guide I know realise the Master section is audio only - no midi control whatsoever. Fine, I can get along with that, then I had trouble with how the master mix for a track was full regardless of crossfader position, but that was a Traktor setting, I had not enabled the crossfader properly. Now, I can even mix in headphones, which was my original goal!

 

I'm having a similar problem. With mine, the Master section does nothing in traktor using the default twitch TSI file (or any other) -

Traktor does not even get any controller messages when I rotate any of these 4 knobs.

Very frustrating that I cannot mage my headphone cue with Twitch, as everything else works just great!

Using Midi Monitor in OSX, with no DJ software running, I see no messages from this section of the Twitch either.

Same if I have TRaktor running, if I have Serato running in settings under Mixer the Monitoring panel is greyed out.

Perhaps in my case its a hardware isue, and I'll just have to scrap my twitch. A shame, I was one of the firs to buy, at an special introductory session at West End DJ when it first came out.