The official Novation forum

Not enough USB controller resources

As the Novation community has developed over the years, it has naturally found the bulk of it's voice on Social Media. To ensure we can be there to discuss and support you as best we can, we’ve decided to close the forum.

The conversation isn’t over, though. We’re waiting for you; come say hi.

Also, be sure to check out some of our friends.

As ever, thank you for your support.

Thanks for reading, The Novation Team

If you're having a technical difficulty, get in touch via http://bit.ly/NovationSupport and our technicians will get back to you as soon as they can!

1 post / 0 new
Bob
Offline
Last seen: 1 year 10 months ago
Joined: 12/21/2015 - 06:57
Not enough USB controller resources

Hello everyone,

I have a Novation Ultranova keyboard that I have been using without problems for a few years with an Acer laptop (Win 7, USB 2 & 3). But now I got a new Asus laptop (Wins 8, USB 2). I tried installing the USB driver, but got the following pop-up message:

"Not enough USB controller resources
The controller does not have enough resources for this device."

I downloaded the newest driver and software (novation-usb-driver-2.6.exe & ultranova-1.4.exe) from the Novation site and installed them, but with the same result. I tried to install both driver and utility on a friends Acer laptop (Win 8), same result. It works fine with my old laptop, but I'm on tour with my new laptop now, so I'm pretty desperate to find a solution. I've written to Novation customer suport a week ago, but so far received no response.

It seems to me, that there is some compatibility problem with Win 8, but maybe I've overlooked something? I tried both USB ports on my laptop, it made no difference. I tried running the UltraNova from the mains on its own power supply as well as USB powered, also made no difference. I tried also connecting with different cables that all worked fine with other devices, still no result. Finally, I tried installing the driver with the device already plugged into the USB port as well as without the device plugged in, no difference. The laptop has no problem in connecting with other USB devices, such as mice, cameras, smartphones, pendrives, external harddisks etc. When I tried connecting the UltraNova, there was nothing else plugged in, not even a mouse. But none of the laptops with Win 8 were able to connect with the device at all, meaning that none of its functions are available (audio interface, DAW controller, sound edit via plugin, librarian).

Here are the details of my new laptop:

Laptop: Asus X205TA-SATM0404G (2 GB RAM, 32 + 64 GB SSD)
Processor: Intel Atom Z3735F 1.33 GHz (x64-based processor)
Operating System: Windows 8.1 with Bing (32-bit)
Peripherals: only the UltraNova
Software: Cubase and/or Ableton Live (I have not decided yet), not installed yet. UltraNova Librarian has been installed, but cannot connect to the keyboard due to said USB problem.

Device Info: Novation UltraNova keyboard bought in 2013, Operating system in 1.1.06 (I would like to update the OS, but that's not possible due to the connection problem.).

I really hope someone can help me out! It will be another 4 months before I can get hold of my old laptop and I'm not in a financial position to buy a new one right now (and also it might not solve anything).

Thanx! :-D